summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLibravatar Björn Esser <besser82@fedoraproject.org>2017-12-14 01:30:54 +0100
committerLibravatar Drew DeVault <sir@cmpwn.com>2017-12-17 15:53:22 -0500
commitc08c805ecd8f2000a35cdeae7b16244d0b3c0528 (patch)
tree8a1a12a32a1d2c40bc4fdb43aa7205362438f65b /CMakeLists.txt
parentRevert "Merge remote-tracking branch 'besser82/bugfix/json-c' into 0.15" (diff)
downloadsway-0.15.1.tar.gz
sway-0.15.1.tar.zst
sway-0.15.1.zip
Adaptions for API change in json-c v0.130.15.1
Lift restriction on json-c <= 0.12.1 ipc-server: Acquire ownership of referenced json_object properly When adding a referenced json_object with an unknown lifetime to another json_object, it must be done with a wrapped call to json_object_get() to acquire the ownership of that json_object.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 99081dca..c4bf3f89 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -48,7 +48,7 @@ if (LD_LIBRARY_PATH)
48 add_definitions(-D_LD_LIBRARY_PATH="${LD_LIBRARY_PATH}") 48 add_definitions(-D_LD_LIBRARY_PATH="${LD_LIBRARY_PATH}")
49endif() 49endif()
50 50
51find_package(JsonC 0.12.1 REQUIRED) 51find_package(JsonC REQUIRED)
52find_package(PCRE REQUIRED) 52find_package(PCRE REQUIRED)
53find_package(WLC REQUIRED) 53find_package(WLC REQUIRED)
54find_package(Wayland REQUIRED) 54find_package(Wayland REQUIRED)