summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLibravatar Drew DeVault <sir@cmpwn.com>2016-01-19 18:50:12 -0500
committerLibravatar Drew DeVault <sir@cmpwn.com>2016-01-19 18:50:12 -0500
commita6b19988c54272dbd9366a7e8fa6b8c459541cb6 (patch)
tree5991fa5cb3c5003b003952365356ad123d3048d4 /CMakeLists.txt
parentMerge pull request #448 from colemickens/libinput (diff)
parentadded basic zsh shell completion for sway, swaybg, and swaygrab (diff)
downloadsway-a6b19988c54272dbd9366a7e8fa6b8c459541cb6.tar.gz
sway-a6b19988c54272dbd9366a7e8fa6b8c459541cb6.tar.zst
sway-a6b19988c54272dbd9366a7e8fa6b8c459541cb6.zip
Merge pull request #440 from SethBarberee/zsh-completions
Basic Zsh auto-completion for --options
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4620ff54..db019083 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -45,6 +45,7 @@ option(enable-swaygrab "Enables the swaygrab utility" YES)
45option(enable-swaymsg "Enables the swaymsg utility" YES) 45option(enable-swaymsg "Enables the swaymsg utility" YES)
46option(enable-gdk-pixbuf "Use Pixbuf to support more image formats" YES) 46option(enable-gdk-pixbuf "Use Pixbuf to support more image formats" YES)
47option(enable-binding-event "Enables binding event subscription" YES) 47option(enable-binding-event "Enables binding event subscription" YES)
48option(zsh-completions "Zsh shell completions" YES)
48option(default-wallpaper "Installs the default wallpaper" YES) 49option(default-wallpaper "Installs the default wallpaper" YES)
49 50
50find_package(JsonC REQUIRED) 51find_package(JsonC REQUIRED)
@@ -120,7 +121,9 @@ if(enable-swaylock)
120 message(WARNING "Not building swaylock - cairo, pango, and PAM are required.") 121 message(WARNING "Not building swaylock - cairo, pango, and PAM are required.")
121 endif() 122 endif()
122endif() 123endif()
123 124if(zsh-completions)
125 add_subdirectory(completions/zsh)
126endif()
124install( 127install(
125 FILES ${CMAKE_CURRENT_SOURCE_DIR}/sway.desktop 128 FILES ${CMAKE_CURRENT_SOURCE_DIR}/sway.desktop
126 DESTINATION share/wayland-sessions 129 DESTINATION share/wayland-sessions