summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLibravatar Drew DeVault <sir@cmpwn.com>2017-06-06 09:34:01 -0400
committerLibravatar GitHub <noreply@github.com>2017-06-06 09:34:01 -0400
commitfd47a30e75cccfc3789eafa4bfabd66f4696099b (patch)
tree10c1529eb56235b303bdbca905e8b80dce47ae6d /CMakeLists.txt
parentRevert "Drop epoll dependency" (diff)
parentFreeBSD fixes (diff)
downloadsway-fd47a30e75cccfc3789eafa4bfabd66f4696099b.tar.gz
sway-fd47a30e75cccfc3789eafa4bfabd66f4696099b.tar.zst
sway-fd47a30e75cccfc3789eafa4bfabd66f4696099b.zip
Merge pull request #1232 from johalun/master-freebsd
FreeBSD fixes
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9ed45830..edf486ca 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -66,7 +66,10 @@ find_package(GdkPixbuf)
66find_package(PAM) 66find_package(PAM)
67 67
68find_package(LibInput REQUIRED) 68find_package(LibInput REQUIRED)
69find_package(Libcap REQUIRED) 69
70if (CMAKE_SYSTEM_NAME STREQUAL Linux)
71 find_package(Libcap REQUIRED)
72endif (CMAKE_SYSTEM_NAME STREQUAL Linux)
70 73
71if (CMAKE_SYSTEM_NAME STREQUAL FreeBSD) 74if (CMAKE_SYSTEM_NAME STREQUAL FreeBSD)
72 find_package(EpollShim REQUIRED) 75 find_package(EpollShim REQUIRED)