summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLibravatar Yacine Hmito <yacine.hmito@gmail.com>2015-12-23 12:22:48 +0100
committerLibravatar Yacine Hmito <yacine.hmito@gmail.com>2015-12-23 12:22:48 +0100
commitf02cf75ff3b759c530f195d320c722bb30380155 (patch)
tree336c267f3f52e416a3406d487ec7a30b54e93250 /CMakeLists.txt
parentMerge pull request #396 from crondog/fixbar (diff)
downloadsway-f02cf75ff3b759c530f195d320c722bb30380155.tar.gz
sway-f02cf75ff3b759c530f195d320c722bb30380155.tar.zst
sway-f02cf75ff3b759c530f195d320c722bb30380155.zip
Use SYSCONFDIR as recommended
- swaylock config path not hardcoded anymore - the unusual and weird FALLBACK_CONFIG_DIR is no more
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 0 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4c349865..adb1650b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2,10 +2,6 @@ cmake_minimum_required(VERSION 3.1.0)
2 2
3project(sway C) 3project(sway C)
4 4
5set(FALLBACK_CONFIG_DIR "/etc/sway" CACHE PATH
6 "Fallback config directory defaults to /etc/sway")
7add_definitions(-DFALLBACK_CONFIG_DIR=\"${FALLBACK_CONFIG_DIR}\")
8
9set(CMAKE_C_FLAGS "-g") 5set(CMAKE_C_FLAGS "-g")
10set(CMAKE_C_STANDARD 99) 6set(CMAKE_C_STANDARD 99)
11set(CMAKE_C_EXTENSIONS OFF) 7set(CMAKE_C_EXTENSIONS OFF)