summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLibravatar Drew DeVault <sir@cmpwn.com>2016-01-08 18:49:42 -0500
committerLibravatar Drew DeVault <sir@cmpwn.com>2016-01-08 18:49:42 -0500
commitb4ea9d492cf6b7c4cd871cfc4da98547596acd63 (patch)
tree995a49d74f5db909a24dd7096c6ed9786d0cdad7 /CMakeLists.txt
parentUnescape string after doing var replacement (diff)
downloadsway-b4ea9d492cf6b7c4cd871cfc4da98547596acd63.tar.gz
sway-b4ea9d492cf6b7c4cd871cfc4da98547596acd63.tar.zst
sway-b4ea9d492cf6b7c4cd871cfc4da98547596acd63.zip
Make wallpaper optional (cmake flag)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 8 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 447fd584..2924c3e4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -45,6 +45,7 @@ option(enable-swaygrab "Enables the swaygrab utility" YES)
45option(enable-swaymsg "Enables the swaymsg utility" YES) 45option(enable-swaymsg "Enables the swaymsg utility" YES)
46option(enable-gdk-pixbuf "Use Pixbuf to support more image formats" YES) 46option(enable-gdk-pixbuf "Use Pixbuf to support more image formats" YES)
47option(enable-binding-event "Enables binding event subscription" YES) 47option(enable-binding-event "Enables binding event subscription" YES)
48option(default-wallpaper "Installs the default wallpaper" YES)
48 49
49find_package(JsonC REQUIRED) 50find_package(JsonC REQUIRED)
50find_package(PCRE REQUIRED) 51find_package(PCRE REQUIRED)
@@ -123,10 +124,12 @@ install(
123 COMPONENT data 124 COMPONENT data
124 ) 125 )
125 126
126install( 127if(default-wallpaper)
127 FILES ${CMAKE_CURRENT_SOURCE_DIR}/wallpaper.jpg 128 install(
128 DESTINATION share/sway 129 FILES ${CMAKE_CURRENT_SOURCE_DIR}/wallpaper.jpg
129 COMPONENT data 130 DESTINATION share/sway
130 ) 131 COMPONENT data
132 )
133endif()
131 134
132feature_summary(WHAT ALL) 135feature_summary(WHAT ALL)