summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLibravatar JerziKaminsky <JerziKaminsky@users.noreply.github.com>2017-04-06 02:42:25 +0300
committerLibravatar Jerzi Kaminsky <JerziKaminsky@users.noreply.github.com>2017-04-07 03:14:16 +0300
commitaa6bd85da147291728acb0828f5c987a02a66193 (patch)
treed160212842d3e6bdf00f5fa2f958db732defefec /CMakeLists.txt
parentMerge pull request #1151 from ascent12/master (diff)
downloadsway-aa6bd85da147291728acb0828f5c987a02a66193.tar.gz
sway-aa6bd85da147291728acb0828f5c987a02a66193.tar.zst
sway-aa6bd85da147291728acb0828f5c987a02a66193.zip
Add libcap check to CMake
- Moved ``<sys/capability.h>`` include inside `__linux__` guard, because all uses are similarly guarded. - <sys/capability.h> is part of an optional devel package, at least in fedora. CMake now explicitly checks that libcap devel files are available. - Added libcap to the list of install packages in .travis.yml, to make the dependency explicit. travis-ci installs the package by default, which is why this hasn't surfaced previously.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ec2c73a2..017b0994 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -66,6 +66,7 @@ find_package(GdkPixbuf)
66find_package(PAM) 66find_package(PAM)
67 67
68find_package(LibInput REQUIRED) 68find_package(LibInput REQUIRED)
69find_package(Libcap REQUIRED)
69 70
70if (CMAKE_SYSTEM_NAME STREQUAL FreeBSD) 71if (CMAKE_SYSTEM_NAME STREQUAL FreeBSD)
71 find_package(EpollShim REQUIRED) 72 find_package(EpollShim REQUIRED)