summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLibravatar Drew DeVault <sir@cmpwn.com>2016-12-02 10:23:30 -0500
committerLibravatar Drew DeVault <sir@cmpwn.com>2016-12-02 10:23:30 -0500
commita4e92ad2723a9c33c029f90f8a2af054bf74e1ce (patch)
tree1fbfcc200c3b9dab244e0b2227327b1fdc7c66b1 /CMakeLists.txt
parentClarify when keyboard/mouse features work (diff)
downloadsway-a4e92ad2723a9c33c029f90f8a2af054bf74e1ce.tar.gz
sway-a4e92ad2723a9c33c029f90f8a2af054bf74e1ce.tar.zst
sway-a4e92ad2723a9c33c029f90f8a2af054bf74e1ce.zip
Deal with LD_LIBRARY_PATH
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 83989ecd..cd816e9b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -48,6 +48,9 @@ option(enable-gdk-pixbuf "Use Pixbuf to support more image formats" YES)
48option(enable-binding-event "Enables binding event subscription" YES) 48option(enable-binding-event "Enables binding event subscription" YES)
49option(zsh-completions "Zsh shell completions" NO) 49option(zsh-completions "Zsh shell completions" NO)
50option(default-wallpaper "Installs the default wallpaper" YES) 50option(default-wallpaper "Installs the default wallpaper" YES)
51option(ld-library-path "Configures sway's default LD_LIBRARY_PATH" "/usr/lib")
52
53add_definitions(-D_LD_LIBRARY_PATH="${ld-library-path}")
51 54
52find_package(JsonC REQUIRED) 55find_package(JsonC REQUIRED)
53find_package(PCRE REQUIRED) 56find_package(PCRE REQUIRED)