summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLibravatar Hummer12007 <hilobakho@gmail.com>2016-07-12 13:44:19 +0000
committerLibravatar GitHub <noreply@github.com>2016-07-12 13:44:19 +0000
commit8fc9f503f9f691144ff65928ca12ddf0b3fde3c7 (patch)
treedc9d63489bf9cfedc8d17db273142abdc532790c /CMakeLists.txt
parentMerge pull request #747 from deklov/clang-format-01 (diff)
downloadsway-8fc9f503f9f691144ff65928ca12ddf0b3fde3c7.tar.gz
sway-8fc9f503f9f691144ff65928ca12ddf0b3fde3c7.tar.zst
sway-8fc9f503f9f691144ff65928ca12ddf0b3fde3c7.zip
Enable using non-annotated tags in git-describe
This fixes the version string
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 813bec4d..83989ecd 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -20,7 +20,7 @@ list(INSERT CMAKE_MODULE_PATH 0
20 ) 20 )
21if(EXISTS ${CMAKE_CURRENT_SOURCE_DIR}/.git) 21if(EXISTS ${CMAKE_CURRENT_SOURCE_DIR}/.git)
22 execute_process( 22 execute_process(
23 COMMAND git describe --always 23 COMMAND git describe --always --tags
24 OUTPUT_VARIABLE GIT_COMMIT_HASH 24 OUTPUT_VARIABLE GIT_COMMIT_HASH
25 OUTPUT_STRIP_TRAILING_WHITESPACE 25 OUTPUT_STRIP_TRAILING_WHITESPACE
26 WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR} 26 WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}