summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLibravatar Calvin Lee <cyrus296@gmail.com>2017-06-07 16:45:28 -0700
committerLibravatar Calvin Lee <cyrus296@gmail.com>2017-06-07 17:49:16 -0700
commit843ad38b3c427adb0bf319e9613d9813c8d9246c (patch)
treee02a5b06e2b6923371fd53724791c147c18a1fa4 /CMakeLists.txt
parentMerge pull request #1232 from johalun/master-freebsd (diff)
downloadsway-843ad38b3c427adb0bf319e9613d9813c8d9246c.tar.gz
sway-843ad38b3c427adb0bf319e9613d9813c8d9246c.tar.zst
sway-843ad38b3c427adb0bf319e9613d9813c8d9246c.zip
Implement Tray Icons
This commit implements the StatusNotifierItem protocol, and enables swaybar to show tray icons. It also uses `xembedsniproxy` in order to communicate with xembed applications. The tray is completely optional, and can be disabled on compile time with the `enable-tray` option. Or on runtime with the bar config option `tray_output none`. Overview of changes: In swaybar very little is changed outside the tray subfolder except that all events are now polled in `event_loop.c`, this creates no functional difference. Six bar configuration options were added, these are detailed in sway-bar(5) The tray subfolder is where all protocol implementation takes place and is organised as follows: tray/sni_watcher.c: This file contains the StatusNotifierWatcher. It keeps track of items and hosts and reports when they come or go. tray/tray.c This file contains the StatusNotifierHost. It keeps track of sway's version of the items and represents the tray itself. tray/sni.c This file contains the StatusNotifierItem struct and all communication with individual items. tray/icon.c This file implements the icon theme protocol. It allows for finding icons by name, rather than by pixmap. tray/dbus.c This file allows for asynchronous DBus communication. See #986 #343
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index edf486ca..c80f6361 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -47,6 +47,7 @@ option(enable-swaybar "Enables the swaybar utility" YES)
47option(enable-swaygrab "Enables the swaygrab utility" YES) 47option(enable-swaygrab "Enables the swaygrab utility" YES)
48option(enable-swaymsg "Enables the swaymsg utility" YES) 48option(enable-swaymsg "Enables the swaymsg utility" YES)
49option(enable-gdk-pixbuf "Use Pixbuf to support more image formats" YES) 49option(enable-gdk-pixbuf "Use Pixbuf to support more image formats" YES)
50option(enable-tray "Enables the swaybar tray" YES)
50option(zsh-completions "Zsh shell completions" NO) 51option(zsh-completions "Zsh shell completions" NO)
51option(default-wallpaper "Installs the default wallpaper" YES) 52option(default-wallpaper "Installs the default wallpaper" YES)
52option(LD_LIBRARY_PATH "Configure sway's default LD_LIBRARY_PATH") 53option(LD_LIBRARY_PATH "Configure sway's default LD_LIBRARY_PATH")
@@ -64,6 +65,7 @@ find_package(Cairo REQUIRED)
64find_package(Pango REQUIRED) 65find_package(Pango REQUIRED)
65find_package(GdkPixbuf) 66find_package(GdkPixbuf)
66find_package(PAM) 67find_package(PAM)
68find_package(DBus)
67 69
68find_package(LibInput REQUIRED) 70find_package(LibInput REQUIRED)
69 71
@@ -90,6 +92,17 @@ else()
90 message(STATUS "Building without gdk-pixbuf, only png images supported.") 92 message(STATUS "Building without gdk-pixbuf, only png images supported.")
91endif() 93endif()
92 94
95if (enable-tray)
96 if (DBUS_FOUND)
97 set(ENABLE_TRAY)
98 add_definitions(-DENABLE_TRAY)
99 else()
100 message(WARNING "Tray required but DBus was not found. Tray will not be included")
101 endif()
102else()
103 message(STATUS "Building without the tray.")
104endif()
105
93include_directories(include) 106include_directories(include)
94 107
95add_subdirectory(protocols) 108add_subdirectory(protocols)