summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLibravatar johalun <johalun0@gmail.com>2017-06-05 13:44:29 +0200
committerLibravatar johalun <johalun0@gmail.com>2017-06-06 09:45:50 +0200
commit7fef2830446e1f98a02f8d8a3bba866b7edd5bd0 (patch)
tree10c1529eb56235b303bdbca905e8b80dce47ae6d /CMakeLists.txt
parentRevert "Drop epoll dependency" (diff)
downloadsway-7fef2830446e1f98a02f8d8a3bba866b7edd5bd0.tar.gz
sway-7fef2830446e1f98a02f8d8a3bba866b7edd5bd0.tar.zst
sway-7fef2830446e1f98a02f8d8a3bba866b7edd5bd0.zip
FreeBSD fixes
Increase _POSIX_SOURCE value where needed. Increase _XOPEN_SOURCE value where needed. Conditionally link to libcap (only on Linux). Possibly some trailing whitespace fixes (automatic).
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9ed45830..edf486ca 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -66,7 +66,10 @@ find_package(GdkPixbuf)
66find_package(PAM) 66find_package(PAM)
67 67
68find_package(LibInput REQUIRED) 68find_package(LibInput REQUIRED)
69find_package(Libcap REQUIRED) 69
70if (CMAKE_SYSTEM_NAME STREQUAL Linux)
71 find_package(Libcap REQUIRED)
72endif (CMAKE_SYSTEM_NAME STREQUAL Linux)
70 73
71if (CMAKE_SYSTEM_NAME STREQUAL FreeBSD) 74if (CMAKE_SYSTEM_NAME STREQUAL FreeBSD)
72 find_package(EpollShim REQUIRED) 75 find_package(EpollShim REQUIRED)