summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLibravatar robotanarchy <robotanarchy@bingo-ev.de>2015-12-22 00:32:41 +0100
committerLibravatar robotanarchy <robotanarchy@bingo-ev.de>2015-12-22 00:32:41 +0100
commit470e59b291b7c5e416f5c43bf14dedb8c379b25e (patch)
tree666437c6bf7e764753d7765ffbdda45ecfd05d9d /CMakeLists.txt
parentadd -fPIC flag (position independent code) like in wlc (diff)
downloadsway-470e59b291b7c5e416f5c43bf14dedb8c379b25e.tar.gz
sway-470e59b291b7c5e416f5c43bf14dedb8c379b25e.tar.zst
sway-470e59b291b7c5e416f5c43bf14dedb8c379b25e.zip
fix backtrace detection in CMake
works on arch (glibc) and void linux (tested with musl libc) now
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bb13ef96..4c349865 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -61,9 +61,9 @@ find_package(PAM)
61 61
62find_package(Backtrace) 62find_package(Backtrace)
63if(Backtrace_FOUND) 63if(Backtrace_FOUND)
64 include_directories(${Backtrace_INCLUDE_DIRS}) 64 include_directories("${Backtrace_INCLUDE_DIRS}")
65 target_link_libraries(${Backtrace_LIBRARIES})
66 add_definitions(-DSWAY_Backtrace_FOUND=1) 65 add_definitions(-DSWAY_Backtrace_FOUND=1)
66 set(LINK_LIBRARIES, "${LINK_LIBRARIES} ${Backtrace_LIBRARIES}")
67 set(SWAY_Backtrace_HEADER "${Backtrace_HEADER}") 67 set(SWAY_Backtrace_HEADER "${Backtrace_HEADER}")
68endif() 68endif()
69 69