summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLibravatar Mikkel Oscar Lyderik <mikkeloscar@gmail.com>2016-01-08 14:41:09 +0100
committerLibravatar Mikkel Oscar Lyderik <mikkeloscar@gmail.com>2016-01-08 15:03:25 +0100
commit15cbc53a771f35e5510b643193c4ba99e9f820a2 (patch)
tree37391772505203dd0ac0b533e89359b0d5d6e040 /CMakeLists.txt
parentReduce duplicate code (diff)
downloadsway-15cbc53a771f35e5510b643193c4ba99e9f820a2.tar.gz
sway-15cbc53a771f35e5510b643193c4ba99e9f820a2.tar.zst
sway-15cbc53a771f35e5510b643193c4ba99e9f820a2.zip
Make IPC binding event support a compile time opt.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9c556b0e..447fd584 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -44,6 +44,7 @@ option(enable-swaybar "Enables the swaybar utility" YES)
44option(enable-swaygrab "Enables the swaygrab utility" YES) 44option(enable-swaygrab "Enables the swaygrab utility" YES)
45option(enable-swaymsg "Enables the swaymsg utility" YES) 45option(enable-swaymsg "Enables the swaymsg utility" YES)
46option(enable-gdk-pixbuf "Use Pixbuf to support more image formats" YES) 46option(enable-gdk-pixbuf "Use Pixbuf to support more image formats" YES)
47option(enable-binding-event "Enables binding event subscription" YES)
47 48
48find_package(JsonC REQUIRED) 49find_package(JsonC REQUIRED)
49find_package(PCRE REQUIRED) 50find_package(PCRE REQUIRED)
@@ -112,6 +113,9 @@ if(enable-swaylock)
112 message(WARNING "Not building swaylock - cairo, pango, and PAM are required.") 113 message(WARNING "Not building swaylock - cairo, pango, and PAM are required.")
113 endif() 114 endif()
114endif() 115endif()
116if(enable-binding-event)
117 add_definitions(-DSWAY_BINDING_EVENT=1)
118endif()
115 119
116install( 120install(
117 FILES ${CMAKE_CURRENT_SOURCE_DIR}/sway.desktop 121 FILES ${CMAKE_CURRENT_SOURCE_DIR}/sway.desktop