summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLibravatar Drew DeVault <sir@cmpwn.com>2016-12-02 16:01:33 -0500
committerLibravatar Drew DeVault <sir@cmpwn.com>2016-12-02 16:01:33 -0500
commit0a1b211e09e9fc82885eaf12c0a3658d36c0bec0 (patch)
tree25ed38ee679ab4e92df4c875b288185e53a3533a /CMakeLists.txt
parentRun config files through sed and install to /etc (diff)
downloadsway-0a1b211e09e9fc82885eaf12c0a3658d36c0bec0.tar.gz
sway-0a1b211e09e9fc82885eaf12c0a3658d36c0bec0.tar.zst
sway-0a1b211e09e9fc82885eaf12c0a3658d36c0bec0.zip
Drop -Denable-binding-event
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 0 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cd816e9b..e314fd73 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -45,7 +45,6 @@ option(enable-swaybar "Enables the swaybar utility" YES)
45option(enable-swaygrab "Enables the swaygrab utility" YES) 45option(enable-swaygrab "Enables the swaygrab utility" YES)
46option(enable-swaymsg "Enables the swaymsg utility" YES) 46option(enable-swaymsg "Enables the swaymsg utility" YES)
47option(enable-gdk-pixbuf "Use Pixbuf to support more image formats" YES) 47option(enable-gdk-pixbuf "Use Pixbuf to support more image formats" YES)
48option(enable-binding-event "Enables binding event subscription" YES)
49option(zsh-completions "Zsh shell completions" NO) 48option(zsh-completions "Zsh shell completions" NO)
50option(default-wallpaper "Installs the default wallpaper" YES) 49option(default-wallpaper "Installs the default wallpaper" YES)
51option(ld-library-path "Configures sway's default LD_LIBRARY_PATH" "/usr/lib") 50option(ld-library-path "Configures sway's default LD_LIBRARY_PATH" "/usr/lib")
@@ -86,9 +85,6 @@ if (enable-gdk-pixbuf)
86else() 85else()
87 message(STATUS "Building without gdk-pixbuf, only png images supported.") 86 message(STATUS "Building without gdk-pixbuf, only png images supported.")
88endif() 87endif()
89if(enable-binding-event)
90 add_definitions(-DSWAY_BINDING_EVENT=1)
91endif()
92 88
93include_directories(include) 89include_directories(include)
94 90