summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLibravatar Fabio Alessandro Locati <me@fale.io>2017-02-25 18:21:55 +0000
committerLibravatar Fabio Alessandro Locati <me@fale.io>2017-02-25 18:21:55 +0000
commit6800c60d4b99cde8271992fc24063d7279d1013c (patch)
tree733cfc953377190b0e9b6e086ca3b6df4c297784 /CMakeLists.txt
parentCorrect typo in swaylock(1) (diff)
downloadsway-6800c60d4b99cde8271992fc24063d7279d1013c.tar.gz
sway-6800c60d4b99cde8271992fc24063d7279d1013c.tar.zst
sway-6800c60d4b99cde8271992fc24063d7279d1013c.zip
Ignore Wimplicit-fallthrough
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 74c79075..f5faba96 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -14,6 +14,7 @@ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall")
14set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wextra") 14set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wextra")
15set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wno-unused-parameter") 15set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wno-unused-parameter")
16set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Werror") 16set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Werror")
17set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wimplicit-fallthrough=0")
17 18
18list(INSERT CMAKE_MODULE_PATH 0 19list(INSERT CMAKE_MODULE_PATH 0
19 ${CMAKE_CURRENT_SOURCE_DIR}/CMake 20 ${CMAKE_CURRENT_SOURCE_DIR}/CMake