summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLibravatar Yacine Hmito <yacine.hmito@gmail.com>2015-12-01 01:23:16 +0100
committerLibravatar Yacine Hmito <yacine.hmito@gmail.com>2015-12-01 19:41:44 +0100
commitf3f77f9ff1912a2b05304ba8a5278f42e16b6c1b (patch)
treedc64bfc3a3fe77cf607c2251f61caa3cb6cdc4a1 /CMakeLists.txt
parentCan customize config fallback directory (diff)
downloadsway-f3f77f9ff1912a2b05304ba8a5278f42e16b6c1b.tar.gz
sway-f3f77f9ff1912a2b05304ba8a5278f42e16b6c1b.tar.zst
sway-f3f77f9ff1912a2b05304ba8a5278f42e16b6c1b.zip
FALLBACK_CONFIG_DIR did not work. Fixed.
- Flag was ignored. Now it's taken into account. - Missing trailing slashes in path now behaves properly.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9e1e1dde..68dd7fa3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2,7 +2,8 @@ cmake_minimum_required(VERSION 3.1.0)
2 2
3project(sway C) 3project(sway C)
4 4
5set(FALLBACK_CONFIG_DIR "/etc/sway/") 5set(FALLBACK_CONFIG_DIR "/etc/sway" CACHE PATH
6 "Fallback config directory defaults to /etc/sway")
6add_definitions('-DFALLBACK_CONFIG_DIR=\"${FALLBACK_CONFIG_DIR}\"') 7add_definitions('-DFALLBACK_CONFIG_DIR=\"${FALLBACK_CONFIG_DIR}\"')
7 8
8set(CMAKE_C_FLAGS "-g") 9set(CMAKE_C_FLAGS "-g")