summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLibravatar Greg V <greg@unrelenting.technology>2016-12-08 15:34:08 +0300
committerLibravatar Greg V <greg@unrelenting.technology>2016-12-09 19:32:07 +0300
commitda26d69cb1b21d582a81af0cad7342fab6596eed (patch)
tree18c24336e664111ba9c3a5bfedec5c340ec0a19d /CMakeLists.txt
parentUse return value of write (diff)
downloadsway-da26d69cb1b21d582a81af0cad7342fab6596eed.tar.gz
sway-da26d69cb1b21d582a81af0cad7342fab6596eed.tar.zst
sway-da26d69cb1b21d582a81af0cad7342fab6596eed.zip
Fix build on FreeBSD
- Make sure CMake always finds absolute paths for Cairo, Pango and GdkPixbuf - Add forgotten json-c include path to swaymsg/CMakeLists.txt - Disable -Werror because of assert warnings - Add correct /proc/pid/file path for FreeBSD - Use libepoll-shim on FreeBSD - Only use Linux capabilities on, well, Linux
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b5796168..f55fadae 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -71,6 +71,10 @@ if(Backtrace_FOUND)
71 set(SWAY_Backtrace_HEADER "${Backtrace_HEADER}") 71 set(SWAY_Backtrace_HEADER "${Backtrace_HEADER}")
72endif() 72endif()
73 73
74if (CMAKE_SYSTEM_NAME STREQUAL FreeBSD)
75 find_package(EpollShim REQUIRED)
76endif (CMAKE_SYSTEM_NAME STREQUAL FreeBSD)
77
74include(FeatureSummary) 78include(FeatureSummary)
75include(Manpage) 79include(Manpage)
76include(GNUInstallDirs) 80include(GNUInstallDirs)