summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLibravatar Drew DeVault <sir@cmpwn.com>2015-12-02 05:34:18 -0500
committerLibravatar Drew DeVault <sir@cmpwn.com>2015-12-02 05:34:18 -0500
commit7a1c8c2939c8581bb47323513b91a94aebf62b36 (patch)
tree717052d8d88f3fd14d26566daa520dbdd3a452fe /CMakeLists.txt
parentMerge pull request #290 from christophgysin/cmake (diff)
parentcmake: build common code only once (diff)
downloadsway-7a1c8c2939c8581bb47323513b91a94aebf62b36.tar.gz
sway-7a1c8c2939c8581bb47323513b91a94aebf62b36.tar.zst
sway-7a1c8c2939c8581bb47323513b91a94aebf62b36.zip
Merge pull request #291 from christophgysin/libs
cmake: build common code only once
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 13 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b9a2e37d..75c61c2a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -41,7 +41,19 @@ add_definitions(-DSWAY_GIT_BRANCH=\"${GIT_BRANCH}\")
41string(TIMESTAMP CURRENT_DATE "%Y-%m-%d" UTC) 41string(TIMESTAMP CURRENT_DATE "%Y-%m-%d" UTC)
42add_definitions(-DSWAY_VERSION_DATE=\"${CURRENT_DATE}\") 42add_definitions(-DSWAY_VERSION_DATE=\"${CURRENT_DATE}\")
43 43
44include_directories(${CMAKE_CURRENT_SOURCE_DIR}/include) 44find_package(Cairo REQUIRED)
45find_package(JsonC REQUIRED)
46find_package(PCRE REQUIRED)
47find_package(Pango REQUIRED)
48find_package(WLC REQUIRED)
49find_package(Wayland REQUIRED)
50find_package(XKBCommon REQUIRED)
51
52include_directories(include)
53
54add_subdirectory(protocols)
55add_subdirectory(common)
56add_subdirectory(wayland)
45 57
46add_subdirectory(sway) 58add_subdirectory(sway)
47add_subdirectory(swaybg) 59add_subdirectory(swaybg)