summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLibravatar Wouter van Kesteren <woutershep@gmail.com>2016-12-17 00:18:39 +0100
committerLibravatar Wouter van Kesteren <woutershep@gmail.com>2016-12-17 01:00:39 +0100
commit09b9106550fc05f71a49a3ddef7db8567c5888ac (patch)
tree8b8c75883ff27ef31588b886f4813177bab80ab2 /CMakeLists.txt
parentMerge pull request #991 from barfoo1/registry_fix (diff)
downloadsway-09b9106550fc05f71a49a3ddef7db8567c5888ac.tar.gz
sway-09b9106550fc05f71a49a3ddef7db8567c5888ac.tar.zst
sway-09b9106550fc05f71a49a3ddef7db8567c5888ac.zip
Use CMAKE_INSTALL_FULL_DATA{,ROOT}DIR
Exherbo installs architecture dependent data in a different place than architecture independent data. More concretely: binaries go in /usr/$chost/{bin,lib}, data goes in /usr/share and configs in /etc, /etc is already configurable through CMAKE_INSTALL_FULL_SYSCONFDIR but the datadir was not. This patch fixes it so that things can be pushed in the right places.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f55fadae..d1c38ce3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -129,14 +129,14 @@ if(zsh-completions)
129endif() 129endif()
130install( 130install(
131 FILES ${CMAKE_CURRENT_SOURCE_DIR}/sway.desktop 131 FILES ${CMAKE_CURRENT_SOURCE_DIR}/sway.desktop
132 DESTINATION share/wayland-sessions 132 DESTINATION ${CMAKE_INSTALL_FULL_DATAROOTDIR}/wayland-sessions
133 COMPONENT data 133 COMPONENT data
134 ) 134 )
135 135
136if(default-wallpaper) 136if(default-wallpaper)
137 install( 137 install(
138 DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}/assets/ 138 DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}/assets/
139 DESTINATION share/sway 139 DESTINATION ${CMAKE_INSTALL_FULL_DATADIR}/sway
140 COMPONENT data 140 COMPONENT data
141 FILES_MATCHING PATTERN "*Wallpaper*" 141 FILES_MATCHING PATTERN "*Wallpaper*"
142 ) 142 )