summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLibravatar Drew DeVault <sir@cmpwn.com>2016-01-08 09:48:24 -0500
committerLibravatar Drew DeVault <sir@cmpwn.com>2016-01-08 09:48:24 -0500
commite2d49afb4a9cf1c333cbb1e18360026508b79a60 (patch)
tree37391772505203dd0ac0b533e89359b0d5d6e040 /CMakeLists.txt
parentMerge pull request #439 from mikkeloscar/bindsym-release (diff)
parentMake IPC binding event support a compile time opt. (diff)
downloadsway-e2d49afb4a9cf1c333cbb1e18360026508b79a60.tar.gz
sway-e2d49afb4a9cf1c333cbb1e18360026508b79a60.tar.zst
sway-e2d49afb4a9cf1c333cbb1e18360026508b79a60.zip
Merge pull request #438 from mikkeloscar/binding-event
Implement IPC binding event (keyboard)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9c556b0e..447fd584 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -44,6 +44,7 @@ option(enable-swaybar "Enables the swaybar utility" YES)
44option(enable-swaygrab "Enables the swaygrab utility" YES) 44option(enable-swaygrab "Enables the swaygrab utility" YES)
45option(enable-swaymsg "Enables the swaymsg utility" YES) 45option(enable-swaymsg "Enables the swaymsg utility" YES)
46option(enable-gdk-pixbuf "Use Pixbuf to support more image formats" YES) 46option(enable-gdk-pixbuf "Use Pixbuf to support more image formats" YES)
47option(enable-binding-event "Enables binding event subscription" YES)
47 48
48find_package(JsonC REQUIRED) 49find_package(JsonC REQUIRED)
49find_package(PCRE REQUIRED) 50find_package(PCRE REQUIRED)
@@ -112,6 +113,9 @@ if(enable-swaylock)
112 message(WARNING "Not building swaylock - cairo, pango, and PAM are required.") 113 message(WARNING "Not building swaylock - cairo, pango, and PAM are required.")
113 endif() 114 endif()
114endif() 115endif()
116if(enable-binding-event)
117 add_definitions(-DSWAY_BINDING_EVENT=1)
118endif()
115 119
116install( 120install(
117 FILES ${CMAKE_CURRENT_SOURCE_DIR}/sway.desktop 121 FILES ${CMAKE_CURRENT_SOURCE_DIR}/sway.desktop