aboutsummaryrefslogtreecommitdiffstats
path: root/packages/main/src/reactions/__tests__/synchronizeConfig.spec.ts
diff options
context:
space:
mode:
Diffstat (limited to 'packages/main/src/reactions/__tests__/synchronizeConfig.spec.ts')
-rw-r--r--packages/main/src/reactions/__tests__/synchronizeConfig.spec.ts8
1 files changed, 3 insertions, 5 deletions
diff --git a/packages/main/src/reactions/__tests__/synchronizeConfig.spec.ts b/packages/main/src/reactions/__tests__/synchronizeConfig.spec.ts
index d3338d0..403a608 100644
--- a/packages/main/src/reactions/__tests__/synchronizeConfig.spec.ts
+++ b/packages/main/src/reactions/__tests__/synchronizeConfig.spec.ts
@@ -24,21 +24,19 @@ import { mocked } from 'jest-mock';
24import type ConfigRepository from '../../infrastructure/config/ConfigRepository'; 24import type ConfigRepository from '../../infrastructure/config/ConfigRepository';
25import SharedStore from '../../stores/SharedStore'; 25import SharedStore from '../../stores/SharedStore';
26import type Disposer from '../../utils/Disposer'; 26import type Disposer from '../../utils/Disposer';
27import { silenceLogger } from '../../utils/log';
28import synchronizeConfig, { serializeConfig } from '../synchronizeConfig'; 27import synchronizeConfig, { serializeConfig } from '../synchronizeConfig';
29 28
30let store: SharedStore; 29let store: SharedStore;
31const repository: ConfigRepository = { 30const repository: ConfigRepository = {
32 readConfig: jest.fn(), 31 readConfig: jest.fn<ConfigRepository['readConfig']>(),
33 writeConfig: jest.fn(), 32 writeConfig: jest.fn<ConfigRepository['writeConfig']>(),
34 watchConfig: jest.fn(), 33 watchConfig: jest.fn<ConfigRepository['watchConfig']>(),
35}; 34};
36const lessThanThrottleMs = 100; 35const lessThanThrottleMs = 100;
37const throttleMs = 1000; 36const throttleMs = 1000;
38 37
39beforeAll(() => { 38beforeAll(() => {
40 jest.useFakeTimers(); 39 jest.useFakeTimers();
41 silenceLogger();
42}); 40});
43 41
44beforeEach(() => { 42beforeEach(() => {