aboutsummaryrefslogtreecommitdiffstats
path: root/packages/main/src/infrastructure/electron/impl/__tests__/lockWebContentsToFile.spec.ts
diff options
context:
space:
mode:
Diffstat (limited to 'packages/main/src/infrastructure/electron/impl/__tests__/lockWebContentsToFile.spec.ts')
-rw-r--r--packages/main/src/infrastructure/electron/impl/__tests__/lockWebContentsToFile.spec.ts7
1 files changed, 1 insertions, 6 deletions
diff --git a/packages/main/src/infrastructure/electron/impl/__tests__/lockWebContentsToFile.spec.ts b/packages/main/src/infrastructure/electron/impl/__tests__/lockWebContentsToFile.spec.ts
index 29c0516..f7bad0a 100644
--- a/packages/main/src/infrastructure/electron/impl/__tests__/lockWebContentsToFile.spec.ts
+++ b/packages/main/src/infrastructure/electron/impl/__tests__/lockWebContentsToFile.spec.ts
@@ -25,7 +25,6 @@ import { fake } from '@sophie/test-utils';
25import type { Event, HandlerDetails, WebContents } from 'electron'; 25import type { Event, HandlerDetails, WebContents } from 'electron';
26import { mocked } from 'jest-mock'; 26import { mocked } from 'jest-mock';
27 27
28import { silenceLogger } from '../../../../utils/log';
29import type Resources from '../../../resources/Resources'; 28import type Resources from '../../../resources/Resources';
30import lockWebContentsToFile from '../lockWebContentsToFile'; 29import lockWebContentsToFile from '../lockWebContentsToFile';
31 30
@@ -59,17 +58,13 @@ const fakeWebContents = fake<WebContents>({
59 } 58 }
60 return this as WebContents; 59 return this as WebContents;
61 }, 60 },
62 loadURL: jest.fn(), 61 loadURL: jest.fn<WebContents['loadURL']>(),
63}); 62});
64 63
65const event: Event = { 64const event: Event = {
66 preventDefault: jest.fn(), 65 preventDefault: jest.fn(),
67}; 66};
68 67
69beforeAll(() => {
70 silenceLogger();
71});
72
73beforeEach(async () => { 68beforeEach(async () => {
74 windowOpenHandler = undefined; 69 windowOpenHandler = undefined;
75 willNavigate = undefined; 70 willNavigate = undefined;