aboutsummaryrefslogtreecommitdiffstats
path: root/packages/main/src/infrastructure/electron/impl/__tests__/hardenSession.spec.ts
diff options
context:
space:
mode:
Diffstat (limited to 'packages/main/src/infrastructure/electron/impl/__tests__/hardenSession.spec.ts')
-rw-r--r--packages/main/src/infrastructure/electron/impl/__tests__/hardenSession.spec.ts8
1 files changed, 4 insertions, 4 deletions
diff --git a/packages/main/src/infrastructure/electron/impl/__tests__/hardenSession.spec.ts b/packages/main/src/infrastructure/electron/impl/__tests__/hardenSession.spec.ts
index ae10677..dc15d68 100644
--- a/packages/main/src/infrastructure/electron/impl/__tests__/hardenSession.spec.ts
+++ b/packages/main/src/infrastructure/electron/impl/__tests__/hardenSession.spec.ts
@@ -21,7 +21,7 @@
21import { URL } from 'node:url'; 21import { URL } from 'node:url';
22 22
23import { jest } from '@jest/globals'; 23import { jest } from '@jest/globals';
24import { each, fake } from '@sophie/test-utils'; 24import { fake } from '@sophie/test-utils';
25import type { 25import type {
26 OnBeforeRequestListenerDetails, 26 OnBeforeRequestListenerDetails,
27 PermissionRequestHandlerHandlerDetails, 27 PermissionRequestHandlerHandlerDetails,
@@ -100,7 +100,7 @@ it('should set permission request and before request handlers', () => {
100 expect(onBeforeRequest).toBeDefined(); 100 expect(onBeforeRequest).toBeDefined();
101}); 101});
102 102
103each(permissions.map((permission) => [permission])).it( 103it.each(permissions.map((permission) => [permission]))(
104 'should reject %s permission requests', 104 'should reject %s permission requests',
105 (permission: Permission) => { 105 (permission: Permission) => {
106 hardenSession(getFakeResources(false), false, fakeSession); 106 hardenSession(getFakeResources(false), false, fakeSession);
@@ -114,7 +114,7 @@ each(permissions.map((permission) => [permission])).it(
114 }, 114 },
115); 115);
116 116
117each([ 117it.each([
118 [ 118 [
119 false, 119 false,
120 'GET', 120 'GET',
@@ -141,7 +141,7 @@ each([
141 [true, 'GET', 'https://clients2.google.com/service/update2/crx/aaaa', false], 141 [true, 'GET', 'https://clients2.google.com/service/update2/crx/aaaa', false],
142 [true, 'GET', 'https://clients2.googleusercontent.com/crx/aaaa', false], 142 [true, 'GET', 'https://clients2.googleusercontent.com/crx/aaaa', false],
143 [true, 'GET', 'https://example.com', true], 143 [true, 'GET', 'https://example.com', true],
144]).it( 144])(
145 'in dev mode: %s the request %s %s should be cancelled: %s', 145 'in dev mode: %s the request %s %s should be cancelled: %s',
146 (devMode: boolean, method: string, url: string, cancel: boolean) => { 146 (devMode: boolean, method: string, url: string, cancel: boolean) => {
147 hardenSession(getFakeResources(devMode), devMode, fakeSession); 147 hardenSession(getFakeResources(devMode), devMode, fakeSession);