aboutsummaryrefslogtreecommitdiffstats
path: root/packages/main/src/controllers/__tests__/initNativeTheme.spec.ts
diff options
context:
space:
mode:
authorLibravatar Kristóf Marussy <kristof@marussy.com>2022-01-09 21:02:36 +0100
committerLibravatar Kristóf Marussy <kristof@marussy.com>2022-01-09 22:17:13 +0100
commit602bce34c8f7c2f8c68dd18f29243e467ed0fb08 (patch)
tree6ac9dab6b892faef42c8d2bb760e4b556756dc39 /packages/main/src/controllers/__tests__/initNativeTheme.spec.ts
parentbuild: Add prettier (diff)
downloadsophie-602bce34c8f7c2f8c68dd18f29243e467ed0fb08.tar.gz
sophie-602bce34c8f7c2f8c68dd18f29243e467ed0fb08.tar.zst
sophie-602bce34c8f7c2f8c68dd18f29243e467ed0fb08.zip
build: Add eslint-plugin-jest
Signed-off-by: Kristóf Marussy <kristof@marussy.com>
Diffstat (limited to 'packages/main/src/controllers/__tests__/initNativeTheme.spec.ts')
-rw-r--r--packages/main/src/controllers/__tests__/initNativeTheme.spec.ts4
1 files changed, 2 insertions, 2 deletions
diff --git a/packages/main/src/controllers/__tests__/initNativeTheme.spec.ts b/packages/main/src/controllers/__tests__/initNativeTheme.spec.ts
index d4068af..16acca5 100644
--- a/packages/main/src/controllers/__tests__/initNativeTheme.spec.ts
+++ b/packages/main/src/controllers/__tests__/initNativeTheme.spec.ts
@@ -49,7 +49,7 @@ beforeEach(() => {
49}); 49});
50 50
51it('should register a nativeTheme updated listener', () => { 51it('should register a nativeTheme updated listener', () => {
52 expect(nativeTheme.on).toBeCalledWith('updated', expect.anything()); 52 expect(nativeTheme.on).toHaveBeenCalledWith('updated', expect.anything());
53}); 53});
54 54
55it('should synchronize themeSource changes to the nativeTheme', () => { 55it('should synchronize themeSource changes to the nativeTheme', () => {
@@ -71,5 +71,5 @@ it('should remove the listener on dispose', () => {
71 ([event]) => event === 'updated', 71 ([event]) => event === 'updated',
72 )![1]; 72 )![1];
73 disposeSut(); 73 disposeSut();
74 expect(nativeTheme.off).toBeCalledWith('updated', listener); 74 expect(nativeTheme.off).toHaveBeenCalledWith('updated', listener);
75}); 75});