aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 10 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index f3076f2f8..c04bfed89 100644
--- a/configure.ac
+++ b/configure.ac
@@ -17,6 +17,7 @@ AS_IF([test "x$enable_apparmor" = "xyes"], [
17 AC_SUBST(HAVE_APPARMOR) 17 AC_SUBST(HAVE_APPARMOR)
18]) 18])
19 19
20
20AS_IF([test "x$enable_apparmor" = "xyes"], [ 21AS_IF([test "x$enable_apparmor" = "xyes"], [
21 AC_CHECK_HEADER(sys/apparmor.h, , [AC_MSG_ERROR( 22 AC_CHECK_HEADER(sys/apparmor.h, , [AC_MSG_ERROR(
22 [Couldn't find sys/apparmor.h... please install apparmor user space library and development files] )]) 23 [Couldn't find sys/apparmor.h... please install apparmor user space library and development files] )])
@@ -146,6 +147,13 @@ AS_IF([test "x$enable_gcov" = "xyes"], [
146]) 147])
147 148
148 149
150HAVE_GIT_INSTALL=""
151AC_ARG_ENABLE([git-install],
152 AS_HELP_STRING([--enable-git-install], [enable git install feature]))
153AS_IF([test "x$enable_git_install" = "xyes"], [
154 HAVE_GIT_INSTALL="-DHAVE_GIT_INSTALL"
155 AC_SUBST(HAVE_GIT_INSTALL)
156])
149 157
150# checking pthread library 158# checking pthread library
151AC_CHECK_LIB([pthread], [main], [], AC_MSG_ERROR([*** POSIX thread support not installed ***])) 159AC_CHECK_LIB([pthread], [main], [], AC_MSG_ERROR([*** POSIX thread support not installed ***]))
@@ -160,7 +168,7 @@ fi
160 168
161AC_OUTPUT(Makefile src/lib/Makefile src/fcopy/Makefile src/fnet/Makefile src/firejail/Makefile \ 169AC_OUTPUT(Makefile src/lib/Makefile src/fcopy/Makefile src/fnet/Makefile src/firejail/Makefile \
162src/firemon/Makefile src/libtrace/Makefile src/libtracelog/Makefile src/firecfg/Makefile \ 170src/firemon/Makefile src/libtrace/Makefile src/libtracelog/Makefile src/firecfg/Makefile \
163src/ftee/Makefile src/faudit/Makefile src/libconnect/Makefile src/fseccomp/Makefile) 171src/ftee/Makefile src/faudit/Makefile src/fseccomp/Makefile)
164 172
165echo 173echo
166echo "Configuration options:" 174echo "Configuration options:"
@@ -179,6 +187,7 @@ echo " whitelisting: $HAVE_WHITELIST"
179echo " private home support: $HAVE_PRIVATE_HOME" 187echo " private home support: $HAVE_PRIVATE_HOME"
180echo " file transfer support: $HAVE_FILE_TRANSFER" 188echo " file transfer support: $HAVE_FILE_TRANSFER"
181echo " overlayfs support: $HAVE_OVERLAYFS" 189echo " overlayfs support: $HAVE_OVERLAYFS"
190echo " git install support: $HAVE_GIT_INSTALL"
182echo " busybox workaround: $BUSYBOX_WORKAROUND" 191echo " busybox workaround: $BUSYBOX_WORKAROUND"
183echo " EXTRA_LDFLAGS: $EXTRA_LDFLAGS" 192echo " EXTRA_LDFLAGS: $EXTRA_LDFLAGS"
184echo " fatal warnings: $HAVE_FATAL_WARNINGS" 193echo " fatal warnings: $HAVE_FATAL_WARNINGS"