aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 2 insertions, 13 deletions
diff --git a/configure.ac b/configure.ac
index feb0b38a6..241865968 100644
--- a/configure.ac
+++ b/configure.ac
@@ -76,14 +76,6 @@ AS_IF([test "x$enable_private_home" != "xno"], [
76 AC_SUBST(HAVE_PRIVATE_HOME) 76 AC_SUBST(HAVE_PRIVATE_HOME)
77]) 77])
78 78
79HAVE_SECCOMP=""
80AC_ARG_ENABLE([seccomp],
81 AS_HELP_STRING([--disable-seccomp], [disable seccomp]))
82AS_IF([test "x$enable_seccomp" != "xno"], [
83 HAVE_SECCOMP="-DHAVE_SECCOMP"
84 AC_SUBST(HAVE_SECCOMP)
85])
86
87HAVE_CHROOT="" 79HAVE_CHROOT=""
88AC_ARG_ENABLE([chroot], 80AC_ARG_ENABLE([chroot],
89 AS_HELP_STRING([--disable-chroot], [disable chroot])) 81 AS_HELP_STRING([--disable-chroot], [disable chroot]))
@@ -196,8 +188,7 @@ AS_IF([test "x$enable_selinux" = "xyes"], [
196# checking pthread library 188# checking pthread library
197AC_CHECK_LIB([pthread], [main], [], AC_MSG_ERROR([*** POSIX thread support not installed ***])) 189AC_CHECK_LIB([pthread], [main], [], AC_MSG_ERROR([*** POSIX thread support not installed ***]))
198AC_CHECK_HEADER(pthread.h,,AC_MSG_ERROR([*** POSIX thread support not installed ***])) 190AC_CHECK_HEADER(pthread.h,,AC_MSG_ERROR([*** POSIX thread support not installed ***]))
199AC_CHECK_HEADER([linux/seccomp.h], HAVE_SECCOMP_H="-DHAVE_SECCOMP_H", HAVE_SECCOMP_H="") 191AC_CHECK_HEADER([linux/seccomp.h],,AC_MSG_ERROR([*** SECCOMP support is not installed (/usr/include/linux/seccomp.h missing) ***]))
200AC_SUBST(HAVE_SECCOMP_H)
201 192
202# set sysconfdir 193# set sysconfdir
203if test "$prefix" = /usr; then 194if test "$prefix" = /usr; then
@@ -208,14 +199,12 @@ AC_CONFIG_FILES([mkdeb.sh], [chmod +x mkdeb.sh])
208AC_OUTPUT(Makefile src/common.mk src/lib/Makefile src/fcopy/Makefile src/fnet/Makefile src/firejail/Makefile src/fnetfilter/Makefile \ 199AC_OUTPUT(Makefile src/common.mk src/lib/Makefile src/fcopy/Makefile src/fnet/Makefile src/firejail/Makefile src/fnetfilter/Makefile \
209src/firemon/Makefile src/libtrace/Makefile src/libtracelog/Makefile src/firecfg/Makefile src/fbuilder/Makefile src/fsec-print/Makefile \ 200src/firemon/Makefile src/libtrace/Makefile src/libtracelog/Makefile src/firecfg/Makefile src/fbuilder/Makefile src/fsec-print/Makefile \
210src/ftee/Makefile src/faudit/Makefile src/fseccomp/Makefile src/fldd/Makefile src/libpostexecseccomp/Makefile src/fsec-optimize/Makefile \ 201src/ftee/Makefile src/faudit/Makefile src/fseccomp/Makefile src/fldd/Makefile src/libpostexecseccomp/Makefile src/fsec-optimize/Makefile \
211src/profstats/Makefile) 202src/profstats/Makefile src/man/Makefile)
212 203
213echo 204echo
214echo "Configuration options:" 205echo "Configuration options:"
215echo " prefix: $prefix" 206echo " prefix: $prefix"
216echo " sysconfdir: $sysconfdir" 207echo " sysconfdir: $sysconfdir"
217echo " seccomp: $HAVE_SECCOMP"
218echo " <linux/seccomp.h>: $HAVE_SECCOMP_H"
219echo " apparmor: $HAVE_APPARMOR" 208echo " apparmor: $HAVE_APPARMOR"
220echo " global config: $HAVE_GLOBALCFG" 209echo " global config: $HAVE_GLOBALCFG"
221echo " chroot: $HAVE_CHROOT" 210echo " chroot: $HAVE_CHROOT"