aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLibravatar netblue30 <netblue30@yahoo.com>2017-02-05 11:50:04 -0500
committerLibravatar netblue30 <netblue30@yahoo.com>2017-02-05 11:50:04 -0500
commitd17ce1322e6e42ca905393545db03a13570da1b0 (patch)
tree86b598adb3ac57adafe55a62996b9e37325a1eec /configure.ac
parentenable strict seccomp filter on overlay options (diff)
downloadfirejail-d17ce1322e6e42ca905393545db03a13570da1b0.tar.gz
firejail-d17ce1322e6e42ca905393545db03a13570da1b0.tar.zst
firejail-d17ce1322e6e42ca905393545db03a13570da1b0.zip
disable --git-install at compile time
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f3076f2f8..252f82cde 100644
--- a/configure.ac
+++ b/configure.ac
@@ -145,6 +145,13 @@ AS_IF([test "x$enable_gcov" = "xyes"], [
145 AC_SUBST(HAVE_GCOV) 145 AC_SUBST(HAVE_GCOV)
146]) 146])
147 147
148HAVE_GIT_INSTALL=""
149AC_ARG_ENABLE([git-install],
150 AS_HELP_STRING([--disable-git-install], [disable git install feature]))
151AS_IF([test "x$enable_git_install" != "xno"], [
152 HAVE_GIT_INSTALL="-DHAVE_GIT_INSTALL"
153 AC_SUBST(HAVE_GIT_INSTALL)
154])
148 155
149 156
150# checking pthread library 157# checking pthread library
@@ -179,6 +186,7 @@ echo " whitelisting: $HAVE_WHITELIST"
179echo " private home support: $HAVE_PRIVATE_HOME" 186echo " private home support: $HAVE_PRIVATE_HOME"
180echo " file transfer support: $HAVE_FILE_TRANSFER" 187echo " file transfer support: $HAVE_FILE_TRANSFER"
181echo " overlayfs support: $HAVE_OVERLAYFS" 188echo " overlayfs support: $HAVE_OVERLAYFS"
189echo " git install support: $HAVE_GIT_INSTALL"
182echo " busybox workaround: $BUSYBOX_WORKAROUND" 190echo " busybox workaround: $BUSYBOX_WORKAROUND"
183echo " EXTRA_LDFLAGS: $EXTRA_LDFLAGS" 191echo " EXTRA_LDFLAGS: $EXTRA_LDFLAGS"
184echo " fatal warnings: $HAVE_FATAL_WARNINGS" 192echo " fatal warnings: $HAVE_FATAL_WARNINGS"