summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLibravatar netblue30 <netblue30@yahoo.com>2018-03-23 20:33:53 -0400
committerLibravatar netblue30 <netblue30@yahoo.com>2018-03-23 20:33:53 -0400
commit7b808e6d3f2bee32e86a42c7bb46154d7c8e1a08 (patch)
tree9822d57fb2cf29937ba808d2c6cb0b814bbcf3f4 /configure.ac
parentsupport Spectre mitigation patch for gcc compiler (diff)
downloadfirejail-7b808e6d3f2bee32e86a42c7bb46154d7c8e1a08.tar.gz
firejail-7b808e6d3f2bee32e86a42c7bb46154d7c8e1a08.tar.zst
firejail-7b808e6d3f2bee32e86a42c7bb46154d7c8e1a08.zip
fixes
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 3 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index d6d4eb874..9a7a9d65e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3,13 +3,11 @@ AC_INIT(firejail, 0.9.53, netblue30@yahoo.com, , http://firejail.wordpress.com)
3AC_CONFIG_SRCDIR([src/firejail/main.c]) 3AC_CONFIG_SRCDIR([src/firejail/main.c])
4#AC_CONFIG_HEADERS([config.h]) 4#AC_CONFIG_HEADERS([config.h])
5 5
6
7AC_PROG_CC 6AC_PROG_CC
8#AC_PROG_CXX 7#AC_PROG_CXX
9AC_PROG_INSTALL 8AC_PROG_INSTALL
10AC_PROG_RANLIB 9AC_PROG_RANLIB
11 10
12
13HAVE_SPECTRE="no" 11HAVE_SPECTRE="no"
14AC_MSG_CHECKING(for Spectre mitigation support in gcc compiler) 12AC_MSG_CHECKING(for Spectre mitigation support in gcc compiler)
15AS_IF([test "$CC" = "gcc"], [ 13AS_IF([test "$CC" = "gcc"], [
@@ -19,14 +17,13 @@ AS_IF([test "$CC" = "gcc"], [
19]) 17])
20AS_IF([test "$HAVE_SPECTRE" = "yes"], [ 18AS_IF([test "$HAVE_SPECTRE" = "yes"], [
21 AC_MSG_RESULT(yes) 19 AC_MSG_RESULT(yes)
22 EXTRA_CFLAGS+="-mindirect-branch=thunk" 20 EXTRA_CFLAGS+=" -mindirect-branch=thunk "
23]) 21])
24AS_IF([test "$HAVE_SPECTRE" = "no"], [ 22AS_IF([test "$HAVE_SPECTRE" = "no"], [
25 AC_MSG_RESULT(... not available) 23 AC_MSG_RESULT(... not available)
26]) 24])
27AC_SUBST([EXTRA_CFLAGS]) 25AC_SUBST([EXTRA_CFLAGS])
28 26
29
30HAVE_APPARMOR="" 27HAVE_APPARMOR=""
31AC_ARG_ENABLE([apparmor], 28AC_ARG_ENABLE([apparmor],
32 AS_HELP_STRING([--enable-apparmor], [enable apparmor])) 29 AS_HELP_STRING([--enable-apparmor], [enable apparmor]))
@@ -35,13 +32,12 @@ AS_IF([test "x$enable_apparmor" = "xyes"], [
35 AC_SUBST(HAVE_APPARMOR) 32 AC_SUBST(HAVE_APPARMOR)
36]) 33])
37 34
38
39AS_IF([test "x$enable_apparmor" = "xyes"], [ 35AS_IF([test "x$enable_apparmor" = "xyes"], [
40 AC_CHECK_HEADER(sys/apparmor.h, , [AC_MSG_ERROR( 36 AC_CHECK_HEADER(sys/apparmor.h, , [AC_MSG_ERROR(
41 [Couldn't find sys/apparmor.h... please install apparmor user space library and development files] )]) 37 [Couldn't find sys/apparmor.h... please install apparmor user space library and development files] )])
42]) 38])
43AS_IF([test "x$enable_apparmor" = "xyes"], [ 39AS_IF([test "x$enable_apparmor" = "xyes"], [
44 EXTRA_LDFLAGS+="-lapparmor " 40 EXTRA_LDFLAGS+=" -lapparmor "
45]) 41])
46AC_SUBST([EXTRA_LDFLAGS]) 42AC_SUBST([EXTRA_LDFLAGS])
47 43
@@ -160,7 +156,7 @@ AC_ARG_ENABLE([gcov],
160 AS_HELP_STRING([--enable-gcov], [Gcov instrumentation])) 156 AS_HELP_STRING([--enable-gcov], [Gcov instrumentation]))
161AS_IF([test "x$enable_gcov" = "xyes"], [ 157AS_IF([test "x$enable_gcov" = "xyes"], [
162 HAVE_GCOV="--coverage -DHAVE_GCOV " 158 HAVE_GCOV="--coverage -DHAVE_GCOV "
163 EXTRA_LDFLAGS+="-lgcov --coverage " 159 EXTRA_LDFLAGS+=" -lgcov --coverage "
164 AC_SUBST(HAVE_GCOV) 160 AC_SUBST(HAVE_GCOV)
165]) 161])
166 162